System Requirements for Moodle

  • 4
  • May 22, 2017

Operating System:

  • Windows 10
  • Mac OS X 10.14 or higher

 Browser:

Some browsers may not support all functionalities in Moodle, such as online quizzes and the HTML editor. You may need to add an exception for your Moodle website to your browser’s pop-up blocker. It is also recommended to disable any pop-up blockers in third-party toolbars that may be installed in your browser.

Internet Connection:

  • Dial-up (load times may be lengthy)
  • DSL
  • Cable

DSL, cable, or a faster Internet connection is recommended for the best user experience.

 Additional Requirements: